Google Colab 2019⇒2020前半でエラーが出るようになったコードの備忘録

6月 16, 2020

該当のコード

エラーが出たところは、以下のコードです。2020年3月頃まではエラーは出なかった。

plt.plot(history.history['acc'],",-",label="accuracy")
plt.plot(history.history['val_acc'],",-",label="val_acc") 

以下のように変えたら治りました。

plt.plot(history.history['accuracy'],",-",label="accuracy")
plt.plot(history.history['val_accuracy'],",-",label="val_acc")

pip listを見たら、tensorflowが1.4から2.0にアップグレードされていました。(以前からアップグレードするよと、警告は前から出ていた) このついでに、matplotlibもアップグレードされたのだろうか?
pip listで
matplotlib 3.2.1 

参考 ・・・https://teratail.com/questions/233667